summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTiger Wang <ziwei.tiger@outlook.com>2020-10-15 11:35:44 +0200
committerGitHub <noreply@github.com>2020-10-15 11:35:44 +0200
commita145980795a4f37ebb9857bddb7427a184bbd6dd (patch)
treefb7ec4db18b92590b5036885c1dc39c3d42f83ca /CMakeLists.txt
parentAdded missing return types and fixed param types (#4996) (diff)
downloadcuberite-a145980795a4f37ebb9857bddb7427a184bbd6dd.tar
cuberite-a145980795a4f37ebb9857bddb7427a184bbd6dd.tar.gz
cuberite-a145980795a4f37ebb9857bddb7427a184bbd6dd.tar.bz2
cuberite-a145980795a4f37ebb9857bddb7427a184bbd6dd.tar.lz
cuberite-a145980795a4f37ebb9857bddb7427a184bbd6dd.tar.xz
cuberite-a145980795a4f37ebb9857bddb7427a184bbd6dd.tar.zst
cuberite-a145980795a4f37ebb9857bddb7427a184bbd6dd.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7bd7c1941..da77aed5a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,13 +88,10 @@ endif()
# Selectively disable warnings in the level where the target is created:
if(CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
# Generated file has old-style casts, missing prototypes, and deprecated declarations
- set_source_files_properties("${CMAKE_SOURCE_DIR}/src/Bindings/Bindings.cpp" PROPERTIES COMPILE_OPTIONS -Wno-everything)
+ set_source_files_properties("${PROJECT_SOURCE_DIR}/src/Bindings/Bindings.cpp" PROPERTIES COMPILE_OPTIONS -Wno-everything)
# File failed to follow NHS guidelines on handwashing and has not maintained good hygiene
- set_source_files_properties("${CMAKE_SOURCE_DIR}/src/IniFile.cpp" PROPERTIES COMPILE_OPTIONS -Wno-header-hygiene)
-
- # Enforce BlockHandler handling all blocks in switch statements
- set_source_files_properties("${CMAKE_SOURCE_DIR}/src/Blocks/BlockHandler.cpp" PROPERTIES COMPILE_OPTIONS -Werror=switch)
+ set_source_files_properties("${PROJECT_SOURCE_DIR}/src/IniFile.cpp" PROPERTIES COMPILE_OPTIONS -Wno-header-hygiene)
endif()
if(${BUILD_TOOLS})